TopN report unable to load metrics

Document ID : KB000046876
Last Modified Date : 14/02/2018
Show Technical Document Details

Issue: 

When running the TopN report in USM, it fails with "Error: could not load metric list"

 

Environment:  

This is general information applicable to most versions of UIM.

 

Cause: 

The cause of this error was found to be special characters in the S_QOS_DATA table.

One or or more of the servers in the USM group had special characters under 'target' or 'source' (could be any column).

These were likely created by a corrupted message or temporary database insert issue.

 

Resolution:

To resolve this issue, the special characters in the database will have to be identified and removed.

There are a variety of ways to search for special chars in a table; could be a query on the database or a text tool.

 

One example is to use TextPad - http://www.textpad.com/add-ons/macros.html

'Find-non-ASCII' package - "If you need to clean your text files of non-ASCII characters. This macro finds any non-aASCII and non-printable ASCII chars"

 

This article shows another option - http://www.ca.com/us/support/ca-support-online/product-content/knowledgebase-articles/tec000005335.aspx

 

Once the rows with special chars has been identified, delete them and the TopN report should run without issue.