Clarity PPM: TMA-0111 timesheet error when adding tasks or saving timesheet

Document ID : KB000025510
Last Modified Date : 08/11/2018
Show Technical Document Details
Issue:

TMA-0111 error when attempting to perform an operation that saves a timesheet, e.g populate, submit, add task, return, etc)
A time entry lock was not deleted from the PRLock table after being locked.

Cause:

There is not a known Steps-to-Reproduce provided by the customer base, therefore the lock will need to be removed.

What is noticed or contributes to the issue is one or more of the following symptoms occur:
1. Deadlocking

2. Services are suddenly stopped during timesheet editing

3. Database connections are closed

Resolution:

Use the following details to resolve the issue.
 


1.Run the following query:

--Oracle
select * from prlock, cmn_sec_users
where cmn_sec_users.id = prlock.pruserid
and prtablename = 'PRTIMESHEET'
and prname = '~prTimeEntry'
and prlockedsince < sysdate - 0.042
 

--MSSQL
select * from prlock
where prtablename = 'PRTIMESHEET'
and prname = '~prTimeEntry'
and prlockedsince < getdate() - 0.042

Please return the results in an XLS file with headers.

2. If the query returns any results, run this query:

--ORACLE
delete from prlock
where prtablename = 'PRTIMESHEET'
and prname = '~prTimeEntry'
and prlockedsince < sysdate - 0.042;
commit;

--MSSQL
delete from prlock
where prtablename = 'PRTIMESHEET'
and prname = '~prTimeEntry'
and prlockedsince < getdate() - 0.042


 

Additional Information:

DE45317 was reported to enable Clarity administrators to remove the timesheet locks via the security.locks page, instead of engaging the DBA team. This is resolved in 15.6.0.

DE45799 was reported to investigate the root cause of the timesheet locks.