Timeout error on IMS commands when multiple FFOR jobs submitted in parallel.

Document ID : KB000045285
Last Modified Date : 14/02/2018
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Issue:

When executing multiple Online Reorganizations in parallel, using CA Database Organizer for IMS for z/OS (DBO), a Timeout error may occur when the ITK Started Task tries to issue an IMS command.

For example:

The DBO jobs fails with the following errors in the job output:

HPO3002E PAUS TIMEOUT WHILE AWAITING A RESPONSE FROM system

HPO0A01E ERROR TRYING TO /DBD DATABASE dbname , R15=0000HPO1101E ERROR TRYING TO /STA DATABASE dbname , R15=0000

HPO1D02E UNABLE TO REINSTATE THE ORIGINAL DATABASE

In the ITK (HPO) Started Task, LXCF error similar to the following, may be seen:

HPO2402E LXCF ERROR, R15=00000008, R0=00000008, FUNCTION=xxxxxxxxHPO2402E ATTEMPTED RESPONSE:GOOD FOR REQUEST:DISC MVS:system IMS:imsid DBD:dbname 

 

Cause:

This is likely to be a legitimate timeout situation. Keep in mind that the more FFORs that are run concurrently, the more likely you are to see timeout issues. 

 

Resolution:

Increase the timeout value by specifying PAUSETIMEOUT=300 (which is 5 mins).
The default value for PAUSETIMEOUT is 60 (seconds).

To override the default value, PAUSETIMEOUT can be added to the control statements of the Reorg Function or to the HPOREORG global Parmlib member.

If this does not resolve the Timeout error, then either increase the value as needed, or contact CA Technical Support for assistance.  

 

Additional Information:

For further details on the PAUSETIMEOUT control statement please refer to docops.ca.com

https://docops.ca.com/ca-database-management-solutions-for-ims-for-z-os/19-incremental/en/managing-database-performance/ca-database-organizer-for-ims/customizing-ca-database-organizer-jcl/ca-database-organizer-control-statements-reference/pausetimeout-dbo-define-ffor-wait-time-limit