Tibco EMS throws "SSL Connection Error Connecting to EM" error.

Document ID : KB000006180
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

After installing the Tibco EMS agent and configuring it for SSL connectivity to the EMS Server, it fails with an error similar to:

1/16/17 09:24:01 AM EDT [ERROR] [com.wily.soaextension.tibcoems.agent.TibcoEMSConnectionManager] Unable to connect EMS server on xxxx.xxx.com:39443
1/16/17 09:24:01 AM EDT [ERROR] [com.wily.soaextension.tibcoems.agent.TibcoEMSConnectionManager] Ensure that an EMS Server exists and running on xxxx.xxx.com:39443, and connecting user has 'VIEW-ALL' permission.

Putting the log level to DEBUG on the agent adds this additional message:
1/16/17 09:24:01 AM EDT [DEBUG] [com.wily.soaextension.tibcoems.agent.TibcoEMSConnectionManager] com.tibco.tibjms.admin.TibjmsAdminException: Unable to connect to server. Root cause:
javax.jms.JMSSecurityException: Failed to connect via SSL to [ssl://xxxx.xxx.com:39443]: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)

 

Environment:
Tibco EMS agent -- all supported releases.
Cause:

This can be caused by being unable to match protocols between the agent and the server.

Resolution:

 To resolve the problem, clear the agent protocol field so that the agent can try to match across all protocols.

 To do this:

 1) Open the agent file TibcoEMSMonitor.properties

 2) Comment out the agent property

 cipher.suites=

 to

 #cipher.suites=

 3) Restart the agent

Additional Information:

If the problem continues, reproduce the problem with debug logging active, and contact CA Technical Support  for further investigation.