The VSE Recorder in the DevTest Portal does not start - Failed to load recording

Document ID : KB000007848
Last Modified Date : 15/10/2018
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Issue:

After providing all the details in the Recording window, running on Portal, the Start Recording button is selected.

This button acts like it is in a loading state and goes back to the initial status - "Start Recording".

It is not possible to record a virtual service using the VSE Recorder in the Portal.

Environment:
DevTest on release 9.5.1
Cause:

For every recording session that is started in the Portal, a new folder is created under $LISA_HOME/vseRecording/<VSEName>_2013 folder.

It looks like something was corrupted inside this folder, not allowing the VSE Recorder to start in the Portal.

We have experienced issues with the vseRecordingĀ folder content getting corrupted when the VSE server runs out of disk space and if the VSE goes down unexpectedly while the recording process, via Portal, was happening.

Resolution:

Stop DevTest components.

Rename the folder $LISA_HOME/vseRecording/<VSEName>_2013 to $LISA_HOME/vseRecording/<VSEName>_2013_old.

Start DevTest components.

When the VSE starts a new VSE_2013 folder is created.

The previous recording sessions won't be available in the Portal - under Virtual Service via Recording/List.