The VSE and Virtual Services are no longer visible in the Portal

Document ID : KB000107665
Last Modified Date : 24/07/2018
Show Technical Document Details
Issue:
When opening the Portal in the browser, the VSE and its Virtual Services are no longer visible.
Opening http://localhost:1507/devtest in the browser,  logging in and opening  'Monitor -> Virtual Service Environments' did not show the VSE even though the VSE was running.

The following error was observed in the registry.log: 
2018-04-16 00:57:52,425Z (10:57) [Thread-13] INFO /jasper-server - 2 Spring WebApplicationInitializers detected on classpath 
2018-04-16 00:57:53,300Z (10:57) [Thread-13] ERROR org.springframework.boot.SpringApplication - Application startup failed 
java.lang.IllegalStateException: Unable to load configuration files 
... 
Caused by: java.util.InvalidPropertiesFormatException: org.xml.sax.SAXException: Invalid system identifier: http://java.sun.com/j2ee/dtds/application_1_2.dtd 
at sun.util.xml.PlatformXmlPropertiesProvider.load(PlatformXmlPropertiesProvider.java:80) 
Environment:
DevTest Portal 10.3
Cause:
The problem occurred after configuring a proxy in local.properties: 
lisa.http.webProxy.host=<<hostname of the proxy>> 
lisa.http.webProxy.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.port=<<proxy port>> 
lisa.http.webProxy.ssl.host=<<hostname of the proxy>> 
lisa.http.webProxy.ssl.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.ssl.port=<<proxy port>> 

This proxy required a login when accessing hosts outside the local network.
Resolution:
Removing the proxy configuration from local.properties and reinstalling DevTest 10.3 resolved the problem.
The following entries were removed: 
lisa.http.webProxy.host=<<hostname of the proxy>> 
lisa.http.webProxy.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.port=<<proxy port>> 
lisa.http.webProxy.ssl.host=<<hostname of the proxy>> 
lisa.http.webProxy.ssl.nonProxyHosts=127.0.0.1 
lisa.http.webProxy.ssl.port=<<proxy port>>

Some Virtual Services required these proxy settings however and these were configured in VirtualServiceEnvironmentService.vmoptions by adding these entries:
-Dlisa.http.webProxy.host=<<hostname of the proxy>>
-Dlisa.http.webProxy.port=<<proxy port>>