The Time-Scale of Custom Time Scaled Value Portlets reverts on advance

Document ID : KB000045384
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem:

In CA PPM, a grid portlet can be created to present time scaled value data, and this portlet can then be included in a portlet page. The problem arises after changing the time-scale being used to display the information in the portlet. Once this time-scale is changed, advancing forward or backward through the dates using the navigation arrows, the time-scale appears to revert back to its default value. This behavior seems to affect custom time scaled value portlets that use custom attributes of an object. 

Steps to Reproduce:

  1. In CA PPM, create a new attribute on the any object (in this example, we use the Assignment object - Administration > Objects > Assignment > Attributes > New). Populate the fields as shown, then save and return:
    1.png
  2.      Create a new Grid Portlet with the Data Provider being the object you created the custom attribute on (Administration > Portlets > select New and Grid Portlet).

  3. Add a Time Scaled Value field under the List Column Section for the custom attribute, populate the settings as desired, and be sure to check Allow Grid Editing Shown in the below example:
    3.png
  4. Add the newly created portlet to any portlet page where applicable, enter values into the time scale value fields and Save. In the top-right settings for the portlet, change the Specific Time Scale to a value other than the default for the field, Save and Return. 
  5. Navigate forward on the portlet using the forward arrow – the time scale reverts back to month and this can be verified by going to change the specific time scale where it shows the default time scale -- not the one that had been set.

Expected Results: For the time-scale of the portlet to keep the time-scale that was set after entering values into the portlet and then navigating forward or backward through the dates

Actual Results: The time-scale of the portlet reverts to the portlet default after navigating forward or backward through the dates of the portlet, causing the user to have to reconfigure the time-scale to enter data at a proper scale

Environment: 

This applies to CA PPM 14.2/14.3

Cause:

The issue is caused by CLRT-81002. 

Resolution:

This issue is currently in the process of being reviewed as CLRT-81002. This page will be updated with the status of that review request. 

Workaround: 

Update the Number of Time Periods when changing the Time Scale so that you can update the necessary amount of Time Scale Value fields in one try, mitigating the need to navigate forward through the time periods.