The Software Content Download Job is Failing With: ERROR [com.ca.sccc.CCConfig] - 'applications' must have at least one application node

Document ID : KB000029711
Last Modified Date : 14/02/2018
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DESCRIPTION:

The CA Client Automation default Content Download job is failing with Error in the \CA\SC\CIC\logs\cic.log file

       ERROR [com.ca.sccc.CCConfig] - 'applications' must have at least one application node.  

This document will detail steps to resolve the error in the CIC.log file " ERROR [com.ca.sccc.CCConfig] - 'applications' must have at least one application node".

 

SYMPTOMS:

1.   Content Download job shows it is in an ERROR status in the DSM Explorer

When looking at the cic.log in the  CA\SC\CIC\Logs\folder you see the following error: 

2015-02-09 17:46:29,857 [CCMain] ERROR [com.ca.sccc.CCConfig] - 'applications' must have at least one application node 2015-02-09
17:46:29,857 [CCMain] ERROR [com.ca.sccc.CCMain] - Failed to complete content server applications configuration
2015-02-09 17:46:29,857 [CCMain] FATAL [com.ca.sccc.CCMain] - Failed to configure CIC, aborting 

 

2.  Running the  util -c commands Fails

When you try to connect to the Content Update website via util- c command you will get an error 8 on the command line and in the util.log file.

2015-02-10 11:22:24,681 [main] ERROR [com.ca.sccc.CCConfig] - 'applications' must have at least one application node 2015-02-10
11:22:24,681 [main] ERROR [com.ca.sccc.CCBatchUtil] - Failed to get applications configuration
2015-02-10 11:22:24,682 [main] ERROR [com.ca.sccc.CCBatchUtil] - Execution terminated due to an error
2015-02-10 11:22:24,682 [main] INFO [com.ca.sccc.CCBatchUtil] - Execution return code: 8 

 

ROOT CAUSE:

The error is caused by the missing Application line for DSM in the config.xml file which is located in the CA\SC\CIC\Conf directory.

<applications>
    <DSM>
         <id>B1B13849-08D1-4DA6-91EA-2D278E5F00CC</id>
        <licenseKey>PMDSM-00000-00000-00001</licenseKey> 
        <MDBRole>ca_itrm_group</MDBRole>
   </DSM>
</applications>

 

RESOLUTION:

To correct the error, go to a command prompt and change directory to \CA\SC\CIC\bin and run the relevant command for the application you are using:

 

UPM -     Util.bat -R UPM 682DCD15-5C94-4321-842D-E3944D3CA000 PMUPM-00000-00000-00001 upmuser_group  sa  <sa password>

SWCM - Util.bat -R SWCM 6EF2944D-DD53-468E-8FAF-98C19D88C2BF SWCM-00000-00000-00001 swcmadmin  sa  <sa password>

DSM -     Util.bat -R DSM B1B13849-08D1-4DA6-91EA-2D278E5F00CC PMDSM-00000-00000-00001 ca_itrm_group  sa  <sa password>