The requested resource was not found https://<UMP>/jasperserver-pro/j_spring_security_check

Document ID : KB000034984
Last Modified Date : 03/08/2018
Show Technical Document Details
Issue:
UMP > Unified Reports displays an error: "Not Found"
From the portal logs you see the following type of errors:

19 Nov 2014 21:30:20,629 ERROR [PortalInitAction:235] Internal Server Error
19 Nov 2014 21:30:20,630 ERROR [PortalInitAction:235] javax.servlet.ServletException: java.lang.RuntimeException: Invalid host name

and
19 Nov 2014 21:30:28,443 ERROR [LayoutAction:872] Reject processAction for http:/<UMP>/web/guest/home on home html

from the wasp log we are seeing the following error:
Nov 19 21:30:20:688 ERROR [http-443-45, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/].[I18n Servlet]] invoke() Servlet.service() for servlet I18n Servlet threw exception
Nov 19 21:30:20:689 ERROR [http-443-45, org.apache.catalina.core.ContainerBase.[wasp-engine].[localhost].[/].[I18n Servlet]] java.lang.RuntimeException: Invalid host name ServerName

Uinified Reporter Error

Resolution:
  1. Log into ump as administrator
  2. Go to the control panel
  3. Go to server administration.
  4. Execute the following:
Clear content cached by this VM.
Clear content cached across the cluster.
Clear the database cache.
Re-index all search indexes.
 
       5. Finally deactivate wasp and activated it again.



 

Additional Information:
Another reason this can happen is that the Unified Reporter was not upgraded.
For example:
UIM and UMP were upgraded to 8.51.
Unified Reporter is still at 8.50
To resolve this run the "Unified Reporter" install for 8.51.