The pre-check installation returns the error: Unable to retrieve DB Timezone, refer to checkinstall.log for details when upgrading.

Document ID : KB000004847
Last Modified Date : 14/02/2018
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Issue:

The pre-check installation returns the error: Unable to retrieve DB Timezone, refer to checkinstall.log for details when upgrading to v14.2 to 15.1

This will happen with customers that are in the GMT timezone. It does not happen when the timezone is changed to any other time zone apart from GMT

 

Steps to Reproduce:

  1. On the CA PPM server set the timezone to (UTC) Dublin, Edinburgh, Lisbon, London 
  2. On the MS SQL Database server set the timezone to (UTC) Dublin, Edinburgh, Lisbon, London
  3. Set the clock to a GMT date for both CA PPM & Database server
  4. Extract the install.jar from the CA PPM 15.1 installation media 
  5. Run the Install.bat/.sh
Environment:
CA PPM 14.2, 14.3,14.4,15.1
Cause:

This is identified as but CLRT-81590 and its in review with our engineering team

Resolution:

To adjust the DB & CA PPM server timezones to non-GMT timezones then continue the upgrade. Changed back to the GMT Timezone after the upgrade has been  successful.

Or 

  1. Navigate to the <Install Media>\checkinstall\ folder
  2. Modify .\checkinstall\checkinstall-config.xml to comment out this line as shown below:
    <!-- <checkscript filename="check-timezones.xml" operations="UPGRADE" environments="OP" phases="BEFORE" bypass="false"/> -->
  3. Run the install.bat/.sh to proceed with the upgrade.