The NFA datasource is showing synchronization failures in Performance Center

Document ID : KB000031791
Last Modified Date : 14/02/2018
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Issue:

The Netflow Analysis (NFA) datasource is showing synchronization failures.  DS_PRODUCT_ID_CHANGED is seen in the DMService.log for the NFA datasource

 

Environment:  

2.4.1 Performance Center

 

Cause:

A possible cause for this issue would be if NFA was running on a VM and the VCAIM monitoring that particular VM was also discovered on the DA itself. If it was, then the likely cause of this is the VM not being returned by the VCENTER during a change detection and being deleted, therefore the NFA item lost its NPC guid connection attributes.

 

Resolution:

On NFA:

  1. Use this URL on the NFA Console server to get the product id: http://localhost/reporterdatasource/productsyncws.asmx
  2. Click on the 'ProductID' link. 
  3. Click on the 'Invoke' button on the next page.  

This will open a new window with the product ID as a string.  Take note of this new product ID: 

  • < string xmlns =" http://netqos.com/ProductSyncWS " > productID </ string >

 

On CAPC:

  1. Open a CAPC shell
  2. mysql netqosportal
  3. select * from data_sources2\G;  Confirm the "SourceType" of the NFA data source
  4. update data_sources2 set SourceGUID='NFA productID ' where SourceType=<SourceType>;
  • EX: update data_sources2 set SourceGUID='1234567890' where SourceType=2;

 

The NFA data source should now synchronize successfully.