The Last Occurrence date/time is not populating for any alarms in CA Spectrum on Solaris.

Document ID : KB000004915
Last Modified Date : 14/02/2018
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Issue:

When looking at any alarm anywhere in Spectrum (ie. cli or the alarms view etc) the Last occurrence date/time shows epoch time. Here is an example: 

D Date Time PCauseId MHandle MName MTypeName Severity LastOccurDate&Time 
061569 10/15/2016 00:21:28 0x10f69 0x14f1af <modelname> SwCiscoIOS CRITICAL 12/31/1969 16:00:00 No No 
1964725 10/14/2016 09:45:06 0x676000b 0x1d1ffe <modelname> AP-Pingable CRITICAL 12/31/1969 16:00:00 No No 

Environment:
Solaris
Cause:

This was due to a bug with the CA Spectrum 64 bit architecture.

Resolution:

This is tentatively scheduled to be fixed in the CA Spectrum 10.2.1 release.

This is resolved in PTF patch Spectrum_10.01.01.PTF_10.1.152 for 10.1.1.  The release notes show:

 

 This is a PTF (Program Temporary Fix) patch for the following issue: 

 

        Symptom: The Last Occurrence attribute is not set properly for alarms on Solaris

 

        Resolution: The Last Occurence attribute is now properly set on all platforms.

(DE247806, 00530748)

 

        NOTE: This solution only resolves the problem for new alarms, existing alarm data is not recoverable.

 

If you need the patch please open a case with CA Support.