The introscope Enterprise Manager fails to startup

Document ID : KB000008977
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

You are unable to startup the Introscope Enterrise Manager, in the  EM log you notice the below ERROR message:

..
11/21/17 12:12:36.161 PM CET [ERROR] [WrapperSimpleAppMain] [Manager] The EM failed to start. null

11/21/17 12:12:36.177 PM CET [INFO] [WrapperSimpleAppMain] [Manager] Shutting down data persistence subsystem
11/21/17 12:12:36.177 PM CET [INFO] [WrapperSimpleAppMain] [Manager] Shutting down the Isengard server
11/21/17 12:12:36.192 PM CET [INFO] [WrapperSimpleAppMain] [Manager] Orderly shutdown complete.
..

After enabling VERBOSE logging you notice the below NullPointerException:

11/21/17 12:12:36.161 PM CET [ERROR] [WrapperSimpleAppMain] [Manager] The EM failed to start. null
11/21/17 12:12:36.161 PM CET [VERBOSE] [WrapperSimpleAppMain] [Manager] 

java.lang.NullPointerException
  at org.garret.perst.impl.AltBtree$BtreeSelectionIterator.refresh(AltBtree.java:1357)
  at org.garret.perst.impl.AltBtree$BtreeSelectionIterator.remove(AltBtree.java:1385)
  at org.garret.perst.impl.PersistentMapImpl$1$1.remove(PersistentMapImpl.java:222)
  at java.util.AbstractCollection.remove(AbstractCollection.java:293)
  at java.util.AbstractSet.removeAll(AbstractSet.java:174)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.storage.GlobalMetaDataPerstStorage.removeKnownStorages(GlobalMetaDataPerstStorage.java:237)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.storage.MultiStorePerstStorage.removeManuallyDeletedStoragesFromIndex(MultiStorePerstStorage.java:822)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.storage.MultiStorePerstStorage.<init>(MultiStorePerstStorage.java:150)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.storage.TransactionTraceStorageSystem.<init>(TransactionTraceStorageSystem.java:434)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.storage.TransactionTraceStorageSystem.<init>(TransactionTraceStorageSystem.java:327)
  at com.wily.introscope.server.enterprise.entity.transactiontrace.TransactionTraceEntity.<init>(TransactionTraceEntity.java:185)
  at com.wily.introscope.server.enterprise.EnterpriseServer.initialize(EnterpriseServer.java:584)
  at com.wily.introscope.server.enterprise.EnterpriseServer.doStart(EnterpriseServer.java:369)
  ..

Note: To enable VERBOSE level, open the <EM_HOME>/config/IntroscopeEnterpriseManager.properties, set log4j.logger.Manager=VERBOSE#com.wily.util.feedback.Log4JSeverityLevel,logfile

Environment:
It can affect any Introscope version
Cause:

The above message is an indicator that the traces database is corrupted.

The cause of corruption could be an unexpected or unclean shutdown of the Introscope EM process

 

Resolution:

Suggestion 1: Reindex the traces database

1) Stop the Introscope EM

2) Delete the EM_HOME/traces/index folder

3) Start the Introscope EM

 

Suggestion 2: If the problem persists, start the  Introscope EM with a new Traces database

1) Stop the Introscope EM

2) Delete the EM_HOME/traces folder

3) Start the Introscope EM