The initial data load to sync CA Asset Portfolio Management to CA Software Asset Manager errors when importing contacts

Document ID : KB000005163
Last Modified Date : 14/02/2018
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Issue:

After performing the initial data load to sync data from CA Asset Portfolio Management (APM) to CA Software Asset Manager (SAM), the import in SAM fails with the following error:  invalid reference in field import_data_source_id.

"<contact_uuid>";"CASAM";"System_MA_User";"";"";"";"";"System_MA_User";"";"";"1";"0";"";"";"";"User for Asset Management and Software Delivery Integration";"insert";"error";"Invalid reference in field ""import_data_source_id"".";"ASP-I2" 

The import data_source_id mentioned in the error is the second column - "CASAM"

Environment:
CA Asset Portfolio Management 14.xCA Software Asset Manager, 3.x or 4.x
Cause:

The data source named CASAM does not exist in CA Software Asset Manager. 

Resolution:

Add the CASAM data source in SAM: 

1.  Login to CA Software Asset Manager as a user in an administrative role

2.  Navigate to Admin -> Master Data -> System -> Data Sources

3.  Click the + icon to add a new data source

NOTE:  The source key and import ID are required (see the * next to the label) and are usually the same

CreateDataSource.png

4.  After saving the new data source, contact CA Support for a cleanup script to enable the 'initial data load' from APM to be run a second time.