The following error appears in the Service Desk login page after a network issue: "AHD04620:Error in definition of PDM_MACRO BUTTON"

Document ID : KB000004966
Last Modified Date : 14/02/2018
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Issue:

After a failure in the connection to the Service Desk server, the login page shows the following error message:

AHD04620:Error in definition PDM_MACRO BUTTON

There are no missing values in the tables usp_pdmMacro and usp_pdmMacroParam.
Users are able to login and work properly in Service Desk after login.

Environment:
Service Desk 14.1 or above
Cause:

During the momentary disconnection of Service Desk, the cache become corrupted causing the error to get prompted.

Resolution:

Use the command pdm_webcache -H and pdm_webcache -b to clean the tomcat and browser cache.

1. In the Service Desk server, open a command prompt window.

2. Type: pdm_webcache -H and hit enter. This command will clear webengine HTMPL cache.

3. Then type: pdm_webcache -b and hit enter. This command will alert users to update browser cache.

4. Refresh the login page in your browser.