Error of install log (class com.netegrity.brlib.customcode.ExistingVersionBreakdown.install() runtime exception)

Document ID : KB000111631
Last Modified Date : 20/08/2018
Show Technical Document Details
Issue:
When a Policy Server was upgraded from R12.52 SP1 (no CR) to 12.52 SP1 CR08, the following behavior occurred.

[Behavior]
Although the installation ended normally, and the process could also be started normally and seemed to operate satisfactorily, one NonFatalErrors was recorded on the following logs.
/install_config_info/CA_SiteMinder_Policy_Server_Install_MM_DD_YYYY_HH_MM_SS.log

[Error message]
Custom Action:
com.netegrity.brlib.customcode.ExistingVersionBreakdown
Status: ERROR
Additional Notes: ERROR - class com.netegrity.brlib.customcode.ExistingVersionBreakdown.install() runtime exception:

[Question]
Although it seems that this NonFatalErrors, please let me know the followings?
1. What does this message mean?
2. What is a factor and trigger for that this message was outputted.
3. Does it affect on some operation of a policy server?
Ā 
Environment:
OS:RedHatEnterpriseLinux 6.5 (64bit)
Siteminder: 12.52SP1 (No CR -> CR08)
Resolution:
>1. What does this message mean?

ExistingVersionBreakdown class is called to check the product version parameters or build number. This message shows that a runtime exception of the class occurred.

>2. What is a factor and trigger for that this message was outputted.

The exception that is reported could be because, one of the values was read incorrectly or was read as NULL.

>3. Does it affect on some operation of a policy server?

If there are no issues seen by the customer, I would suggest that the verion entries in 'smregistry' and in '.com.zerog.registry.xml' be verfied to ensure correct version details are updated in these files. Also, check the PS version in command prompt. in PS, if linux, source the env script and then in bin folder, run Version that gives the PS version.