The date format in CA Spectrum's OneClick Event tab filter cannot be changed to DD/MM/YYYY

Document ID : KB000007341
Last Modified Date : 14/02/2018
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Issue:

The Date format in OneClick Event tab filter cannot be changed to DD/MM/YYYY. Even if the machine locale is changed, this does not change the format from MM/DD/YYYY to DD/MM/YYYY.

Cause:

The same issue is seen with the Alarm tables showing in the OneClick console, but this can be adjusted.

The OneClick (or any Java) application uses the JVM locale and the JVM locale is decided by the System locale.

In windows, the JVM (from Java 1.7 onwards, http://bugs.java.com/bugdatabase/view_bug.do?bug_id=7073906) picks the system locale only if the 'DISPLAY' language is set. Otherwise it falls back to default en_US.

After setting the "DISPLAY" language, the alarm table is showing the format DD/MM/YYYY.

But it is still not showing correct in the Event table.

Resolution:

CA is able to reproduce this in house.  This is tentatively scheduled to be fixed in CA Spectrum release 10.3.which is currently scheduled to be released in the end of the second half of calendar year 2017.