The "Clear" button on the Filter is clearing attribute values configured as "Read-Only"

Document ID : KB000121206
Last Modified Date : 14/11/2018
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Issue:
After click on the "clear" button on a filter, the default value(s) for all fields are cleared, even for attributes configured as "Read-Only".

STEPS TO REPRODUCE 
 
1. Add a text field to the Project object (or use an existing one, for instance Text 6 field) 
2. Create a new Portlet, using the Project object as the Data Provider 
3. Select some Attributes to be displayed on its Layout (f.i. Name, Investment ID, Investment type, Manager, Text 6) 
4. Add some Attributes to the Filter Layout as well, (f.i. Name, Manager, Text 6) 
5. In the List Filter Section, select the Tex 6 Field and click on Properties 
Portlet: Raul Test Filter Clear Filter - List Filter Fields 
6. Select the options "Filter Default" (enter a value, for instance "raul") 
7. Mark the options "Required in Filter" and "Read-Only in Filter". 
8. Configure several Projects to have the "Text 6" attribute set to "raul". 
9. Add the portlet to some page (Like to Overrview:General) 
10. The Portlet displays the list of Projects having "Text 6" set to "raul" 
11. Click on Clear button on the Filter Section of the Portlet 

 
Expected Results: Any data entered should be cleared, except the one in the Field "Text 6" 
Actual Results: The "Text 6" predefined value set to "raul" is cleared out. 
Since the Field is read-only the portlet is no longer usable. It is necessary to log out and log in again.
Cause:
This is caused by Defect DE45036
Resolution:
Defect DE45036 is being addressed in 15.5.1