The CA Spectrum OneClick client still shows: "Failed to validate certificate" after installing one of the patches for the java certificate update per TEC1903096

Document ID : KB000047192
Last Modified Date : 14/02/2018
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Issue: 

I have recently updated my Spectrum version to update the CA Java Certificate, but I am still getting a Java Security warning when I try to launch the OneClick Console.

“Failed to validate certificate. The application will not be executed.”

java-sec_error.PNG

Environment:  

Spectrum 9.4.x
Spectrum 10.x
All OS

Cause: 

The Spectrum update contains the new CA Java Certificate, but Java is still using the old Certificate.

Resolution:

Depending upon Java settings, you may need to do one or all of the following:

1.  Clear your java cache

a.  On your client machine, launch the Java Control Panel

b.  In the "General" tab select the "Settings..." button under the Temporary Internet Files.

c.  Select the "Delete Files" and select all 3 options.

d.  Click Ok.

 

2.  Restore your java security prompts

a.  On your client machine, launch the Java Control Panel

b.  In the "Security" tab select the "Restore Security Prompts" and select the "Restore All" option.

java_prompts3.png

java_prompts2.png

 

3.  Remove the old CA Java Certificate from Java Security settings and relaunch the OneClick console. Java will prompt to download the new Certificate.

java_security_remove.png

 

one_click_java_cert_download.png

Additional Information:

 

Notice on Java Certificate Expiry on October 16.2016

 

http://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.tec1903096.html