The CA Spectrum Mobile App will not connect over SSL/HTTPS when using a Self Signed Cert.

Document ID : KB000047581
Last Modified Date : 14/02/2018
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Problem:

When trying to use the CA Spectrum Mobile App with a self signed SSL certificate, authentication fails.

Cause:

Self Signed certificates are not supported.  In order for a self signed certificate to work with a java application, there are parameters needed that violate the Google App Store policies.  To be in compliance with the Google App Store contractual terms, the CA Mobile App only supports a CA certificate issue by one of the certificate authority companies.

Solution:

Obtain a certificate authority (CA) cert and utilize that with CA OneClick and the CA Spectrum Mobile App.

Workaround:

You can use the CA Spectrum WebClient on your mobile device.  Please note that the WebClient is not officially supported on mobile devices, and may or may not work depending on the operating system you have.