The application experienced an internal error loading the SSL libraries

Document ID : KB000046853
Last Modified Date : 05/09/2018
Show Technical Document Details
Issue:

When downloading a Microsoft document attachment on ServiceDesk SSL system, the following error pops up:
"The application experienced an internal error loading the SSL libraries"

ssl_error.jpg

 

Environment:
ServiceDesk 12.x-14.x
Microsoft Windows 7 - 8
Microsoft Internet Explorer
The error will not occur when using Firefox or Chrome
Cause:
The error is Microsoft generated Error caused by Microsoft Windows update.
Resolution:
There are a few possible solutions to this issue:

Solution 1: Settings the "save_as_dialog" option from "NO" to "YES" may provide a resolution. Details on how to complete the change is located here:

https://comm.support.ca.com/kb/enable-download-prompt-for-attachments/kb000052152

Solution 2: Microsoft has provided some updates that may provide a solution to this issue. They are detailed in the documents below.

1. https://social.technet.microsoft.com/Forums/Sharepoint/en-US/78f64ac7-e68c-4171-b940-98f68e27279c/the-application-experienced-an-internal-error-loading-the-ssl-libraries-word-2013?forum=officeitpro
2. https://blogs.technet.microsoft.com/office_integration__sharepoint/2015/04/20/office-2013-error-certificate-error-the-application-experienced-an-internal-error-loading-the-ssl-libraries-when-opening-files/