Test fails when adding Spectrum as a data source where Spectrum is using SSL/TLS

Document ID : KB000117547
Last Modified Date : 15/10/2018
Show Technical Document Details
Issue:
Cannot successfully test/add Spectrum data source to CA Performance Center where Spectrum is configured to use SSL/TLS
Environment:

CA Performance Mangement
Spectrum configured to use SSL/TLS


1) Already verified the Spectrum certificate was imported into CA PC:

https://comm.support.ca.com/kb/After-Configuring-Spectrum-for-SSL-it-now-shows-Unable-to-Contact-in-the-CAPC-data-source-list/KB000032485

2) Already verified axis2.xml file is correct:

https://comm.support.ca.com/kb/data-source-spectrum-through-https/KB000077703

Cause:
The hostname being used in the Add Data Source dialog does not match the Subject Alternative Name or Common Name in the certificate
Resolution:

Make sure the hostname being used in the Add Data Source dialog matches the Subject Alternative Name or Common Name in the certificate.

For example, if the certificate uses the fully qualified domain name (most likely) then this must be used