TeamCenter with a 'non-standard' application

Document ID : KB000095349
Last Modified Date : 10/05/2018
Show Technical Document Details
Issue:
We have an application which is initiated by a message on an  MQ Queue. This application doesn't show up in TeamCenter. Team Center requires Transaction Traces and there doesn't appear to be any 'sampled' transaction traces being captured! There are metrics being captured under Frontend nodes.
Cause:
Problem is really that there are backends before frontend . The system will try to detect frontend which has no backends in level above and iterate if we found frontend which is too deep and has backends above. But in this case, it is not able to find suitable frontend.


 
Resolution:
This situation is currently not handled enhancement request raised

There is a new feature however in 10.7 SP1 already which will provide
- Queue Manager nodes in ATC-Infra layer with performance metrics mapped
- New MQ_Queue node on ATC with both Inferred backend as well as corresponding Queue performance metrics
- ATC map when MQ classes for java is used for JMS messaging