TDoD Error 101 while testing server licence

Document ID : KB000007818
Last Modified Date : 14/02/2018
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Issue:

When trying to start the Test Data on Demand (TDoD) service either in the Windows Services window or the TDoD Configuration Editor, I am receiving the following error message:

Starting TDoD Service 
TDoD Service status is currently set to Stopped 
TDoD Service status is currently set to Stopped 
Starting TDoD Service... 
Unable to start TDoD Service in specified interval. Please check service logs for any error 

C:\Grid-Tools\TDoD\TDoD_Service\logs\tdod.log 
INFO GTWCFHost.GTWCFHost - Validating License 
INFO GT.TDMoD.Services.Databases.DatabaseAccessor - ExecuteQuery sSQL=select pk_gtrep_lic.f_get_clob (@lClobID) 
from gtrep_system 
INFO GT.TDMoD.Services.Databases.DatabaseAccessor - ExecuteQuery >> ExecuteReader 
INFO GT.TDMoD.Services.Security.Licence - ReturnServerLicence lsServerLicence is empty 
FATAL GTWCFHost.GTWCFHost - Exception occurred while opening service 
FATAL GTWCFHost.GTWCFHost - Exception Code: licence_error_testing_licence_contact_support. Exception Message: Error 101 while testing server licence! Please contact support. 
FATAL GTWCFHost.GTWCFHost - Stack Trace: at GT.TDMoD.Services.Security.Licence.ReturnServerLicence(String lsServerLicence) 
at GT.TDMoD.Services.Security.Licence.TestServerLicence() 
at GTWCFHost.GTWCFHost.OnStart(String[] args) 
FATAL GTWCFHost.GTWCFHost - Exception occurred while opening service host connection 
FATAL GTWCFHost.GTWCFHost - Exception: Exception of type 'GT.TDMoD.Services.Common.BusinessException' was thrown.

Environment:
CA Test Data Manager (TDM)- Test Data on Demand (TDoD) & Datamaker
Cause:

You will receive this error message if you do not have a valid license applied in Datamaker. 

Resolution:

Apply a Test Data Manager license to Datamaker using these instructions: https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1469466.html 


Once applied, try restarting the TDoD service. Make sure your configurations are correct using these instructions: https://docops.ca.com/ca-test-data-manager/4-4/en/installing/install-ca-test-data-manager/install-test-data-on-demand/install-and-configure-test-data-on-demand 

Additional Information:

If you experience any further issues, please open a support case by going to https://www.ca.com/us/services-support/ca-support/contact-support.html.