TDM Portal services failing to start after configuring it with Active Directory and enabling Integrated Security on the Repository with MS SQL Server

Document ID : KB000008318
Last Modified Date : 14/02/2018
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Issue:

Using MS SQL Server as repository and Integrated Authentication.

Launching TDM Portal service as Windows user is failing to start some of the services like TDMvDataService, TDMDataReservationService, and TDMModelService.

The startup.log located under 'C:\ProgramData\CA\CA Test Data Manager Portal\logs' is showing errors like "Failed to start component..." followed by the service it failed to start. 

The Windows user, part of the AD group, used to log in to the Service has the Administrator privileges on the local machine and as well as database.  

Environment:
CA TDM Portal 4.2
Cause:

The issue causing this error is at the SQL driver level. The sqljdbc42_4-2.jar used in the TDMvDataService of the Portal is not compatible with the Integrated Security.

Resolution:

The steps below will enable you to connect to MS SQL Server DB (MSSQL DB), that allows only Windows (Integrated) authentication and also start the TDM Portal service successfully.

1. Remove sqljdbc_<version>.jar i.e. sqljdbc42-4.2.jar file from C:\Program Files\CA\CA Test Data Manager Portal\tomcat\webapps\TDMvDataService\WEB-INF\lib

2. EXCEPT for the sqljdbc-4.2.jar under tomcat/lib, remove any sqljdbc_<version>.jar existing in any other sub directory under in tomcat/webapps.

3. Start TDM Portal service as Windows user as shown here:

 PortalUser.JPG

4. Restart the Portal Service 

Additional Information:

If you experience any issues, please open a support case either by going to https://support.ca.com or calling CA Support at one of these numbers- https://www.ca.com/us/services-support/ca-support/contact-support.html

We also would recommend enabling debugging for Portal and sending the resulting log file to support when you open the case. Here are directions on how to do this: https://support.ca.com/us/knowledge-base-articles.TEC1254734.html

 

If you are experiencing this issue with Subset, you may also face the issue with Fast Data Masker (FDM). Here are directions on how to connect to FDM with MS SQL Server using Windows authentication: https://support.ca.com/us/knowledge-base-articles.TEC1139049.html 

 

If you are also experiencing similar issue with Subset, here are directions on how to connect Subset with MS SQL Server using Windows authentication: https://support.ca.com/us/knowledge-base-articles.TEC1568192.html