TDM Portal: "ERROR: Publish failed for job XXXX, Call to ConnectionManagerService failed:"

Document ID : KB000004832
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

How to overcome the following error message found when a user submits a job from the "Self Service Catalog" of the portal.

"ERROR: Publish failed for job XXXX, Call to ConnectionManagerService failed:"

Environment:
TDM Portal
Cause:

A TDM user who is not linked to any connection profile will face this error message. 

Steps to reproduce:

1. Launch the TDM Portal and submit a job from the "Self Service Catalog" designed for your use.

2. After you have submitted your job, you will face the following error message.

When you submit a job from TDM Portal, it throws an error "ERROR: Publish failed for job XXXX, Call to ConnectionManagerService failed: : HttpClientErrorException: 404 Not Found 

End date and time: 2016/11/04 12:48:12" 

Debugging Steps:

1. Switch on the debugging of the Portal by following the steps mentioned in the article below.

https://www.ca.com/us/services-support/ca-support/ca-support-online/knowledge-base-articles.TEC1254734.html?intcmp=searchresultclick&resultnum=2

2. In the Connection Profile logs, you will see the following error message. (This is an example)

2016-12-05 17:56:42.677 UTC [DEBUG] [http-nio-8443-exec-8     ] --- [U:##Removed Userid##][M:GET][P:/api/ca/v1/connectionProfiles/TDOD_DEV]                       c.c.t.c.s.ConProfileService:  RequestID: 133, Module: CONNECTION_PROFILE_MANAGER,getProfile for user 1130 and profile TDOD_DEV

2016-12-05 17:56:42.728 UTC [DEBUG] [http-nio-8443-exec-8     ] --- [U:##Removed Userid##][M:GET][P:/api/ca/v1/connectionProfiles/TDOD_DEV]              c.c.t.c.e.h.GlobalExceptionConvertor:  HTTP Error - NOT FOUND: Connection profile not found.

It means that the user with id = 1130 is not linked to the connection profile

 

Resolution:

Steps to link a user to a connection profile:

To do that, you should first make sure that the user is part of a group. You then link the connection profile that is being used by the self service flow to the group or the user.

1. Add user to a group.

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2.   Link connection profile to group

 

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Additional Information:

If you face any issues or have any questions about the steps, please open a support case by going to https://support.ca.com/irj/portal/anonymous/newhome or by calling customer care at http://www3.ca.com/us/support/customer-assistance.aspx.