TDM DB2 Connectivity - [IBM][CLI Driver] SQL1031N Error

Document ID : KB000008278
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

When trying to connect IBM DB2 database with TDM, I am receiving the following error message:
[IBM][CLI Driver] SQL1031N  The database directory cannot be found on the indicated file system. SQLSTATE=58031

 

Here is the scenario from when the issue was faced:

  • The window ODBC configuration was setup correctly and we received ” Connection Tested Successfully” on testing the connection.
  • When you try to connect the same ODBC connection in Datamaker the above error is returned.
Environment:
CA Test Data Manager (TDM)
Cause:

It sounds like the error is something to do with the database itself. However, the resolution for this issue has nothing to do about the database. It is related with the client environment that is trying to connect to the DB2 database server.

 

Resolution:
  1. Go to Start-> Run. Type compmgmt.msc.  It will lead you to the computer manager.

  2. Go to Local User and Groups -> Groups, and click on DB2ADMNS.

  3. Add the name of the user logged into Windows on it. Click OK to apply.

  4. Click on DB2USERS. Add the same user into it. Click OK to apply.

  5. After this, log off from the machine and log back in. This is important else it will not work.
Additional Information:

If you experience any further issues, please open a support case on https://support.ca.com/irj/portal/newhome or call support at one of these numbers https://www.ca.com/us/services-support/ca-support/contact-support.html.