Tasks not executing after update of calendar

Document ID : KB000092616
Last Modified Date : 29/05/2018
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Issue:
The Calendar in Dollar Universe used to have limited range.
Therefore it can be necessary to update the Calendar in order to include future years.

After such a Calendar update certain Tasks are not scheduled anymore.

The following error appears in universe.log:
|WARN |X|IO |pid=<pid>| u_cal_loadTAPlanified     | End of validity range not set for job, defaulting to the last day of the calendar.
Environment:
The error message is for DUAS v5.6, the message may be different for DUAS v6.x
Cause:
When the validity date (=start date) of a Task falls before the first year of the Calendar definition, the next execution of the Task cannot be calculated. 
Resolution:
Make sure that all validity date of all Task are within the range of the Calendar definition:

- Modify the validity date of Tasks
or
- Add previous years to the Calendar definition