"Task submitted. No changes have been made." when a PolicyXpress is setting an attribute on the IM object

Document ID : KB000046154
Last Modified Date : 14/02/2018
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Symptoms: 

When using an Identity Manager task that modifies an IM object via a Policy Xpress policy, the task submission will fail with the message "No changes have been made"

Environment:  

Any IM version

Cause: 

This error occurs because the PX policy may be triggered too late in the event chained. For example, this error will appear if that PX run on task completion.

Resolution

Move the PX Event trigger earlier in the task flow. The ideal place would be at the beginning of the ModifyUserEvent, or on Task Submission.