System failure(s): insufficient system environment, please check the installation (ASP-3)

Document ID : KB000044477
Last Modified Date : 14/02/2018
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Issue:

Attempting to upgrade CA Software Asset Manager from 3.x to 4.1. An error is received when attempting to launch CA Software Asset Manager.

 

Environment:

CA Software Asset Manager 4.1

 

Cause:

Insufficient Permissions.

Running Check Installation Utility on the current installation will confirm that all is working properly in the install prior to upgrade to avoid any post-upgrade confusion about the source of problems (if any): 

 

Resolution:

Check the application permissions per the CA Software Asset Manager Release 4 Upgrade Manual

Set application permissions

1. Both IUSR and IIS_IUSRS (create if not already present) must have Read, Write, and Modify permission for the following folders:

c:\Program Files (x86)\ca\Sam\app\htdocs\

c:\Program Files (x86)\ca\Sam\app\includes\

c:\Program Files (x86)\ca\Sam\app\uploads\

c:\Program Files (x86)\ca\Sam\tmp\

%TEMP% (System Tempdir)

 

2. User IUSR (IIS_IUSRS on some systems) must have Read and Read & Execute permission for the folder:

c:\Program Files (x86)\ca\Sam\env\

 

3. Verify the upload_path in the config.ini file is set correctly. Use double backslashes and double quotes for Windows, a trailing slash at the end is mandatory.  example Windows: "C:\\app\\uploads\\"

 

Additional Information:

Running Check Installation Utility on the current installation will confirm that all is working properly in the install prior to upgrade to avoid any post-upgrade confusion about the source of problems (if any): See the: CA Software Asset Manager Release 4 Upgrade Manual for further information.

https://support.ca.com/phpdocs/7/8572/CA_SAM_Rel4_Upgrade_Manual.pdf