SYNC not correctly reset on Job abort

Document ID : KB000087371
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
N/A

In the following scenario, described by an example, a SYNC-Object is not correctly reset.

0EMb0000000IUYk.png

The job inside the Workflow fails. The task properties of the job and the end-object can be seen in the screenshot.
The top Workflow has the following Sync condition:

 
0EMb0000000IUYp.png

At the beginning, the current status shown in the Sync monitor is AVAIL 0 (see first screenshot above).
Starting the Workflow, the job goes to status blocked and the Sync monitor shows EXCL 1, which is as expected.

 
0EMb0000000IUYu.png

Now release the blocked Workflow:
 
0EMb0000000IUYz.png

The current status is not set to AVAIL 0, as expected:
 
0EMb0000000IUZ4.png

It is expected that the status is set back to AVAIL 0, because the use of Block or Abort in Else
 
0EMb0000000IUZ9.png

The Sync status is reset to AVAIL 0 after the procedure above.
Environment:
OS Version: N/A
Cause:
Cause type:
Defect
Root Cause: Sync's are not released after a Workflow aborts by the last task within the Workflow.
Resolution:
Update to a fix version listed below or a newer version if available.

Fix Status: Released

Fix Version(s):
Component(s): AE Server and Initialdata
Automation Engine 12.1.0 - Available
Automation Engine 12.0.3 - Available
Automation Engine 11.2.6 - Available
Additional Information:
Workaround :
N/A