Sybase replication probe keeps on crashing sybase_rs

Document ID : KB000113261
Last Modified Date : 18/09/2018
Show Technical Document Details
Issue:
Sybase replication probe keeps on crashing.
Error: Max restart reached for probe
Environment:
sybase_rs 
Probe version: 1.42 
Linux robot
Resolution:
Open the IM configuration for the "controller" probe on that robot, and go to the "Setup" > "Environment" tab, do you see a Variable defined for "LD_LIBRARY_PATH".
If defined, check that it includes the path to the Sybase library folder.
It should look something like the following:
LD_LIBRARY_PATH: /opt/sybase/ASE-15_0/lib:/opt/sybase/DataAccess64/ODBC/lib:/opt/sybase/DataAccess/ODBC/lib:/opt/sybase/OCS-15_0/lib:/opt/sybase/OCS-15_0/lib3p64:/opt/sybase/OCS-15_0/lib3p:/opt/sybase/ASE-15_0/lib:/opt/sybase/DataAccess64/ODBC/lib:/opt/sybase/DataAccess/ODBC/lib:/opt/sybase/OCS-15_0/lib:/opt/sybase/OCS-15_0/lib3p64:/opt/sybase/OCS-15_0/lib3p
Also, these environment variables also need to be defined in the controller >
"Environment' configuration.
For example:
SYBASE: /opt/Sybase
SYBASE_ASE: ASE-15_0
SYBASE_JRE_RTDS: /opt/sybase/shared/SAPJRE-7_1_011_64BIT
SYBASE_OCS: OCS-15_0
SYBASE_WS: WS-15_0 SYBROOT: /opt/sybase
One of these environment variables being missing or pointing to the wrong location would be the most likely cause for it failing to start.
Additional Information:
sybse_rs probe requirements:
https://docops.ca.com/ca-unified-infrastructure-management-probes/ga/en/alphabetical-probe-articles/sybase_rs-sybase-replication-server-monitoring/sybase_rs-sybase-replication-server-monitoring-release-notes#sybase_rs(SybaseReplicationServerMonitoring)ReleaseNotes-PreconfigurationRequirements