Support Automation Closure Message Not Always Displayed

Document ID : KB000096850
Last Modified Date : 17/05/2018
Show Technical Document Details
Issue:
If an employee attempts to access the live chat feature outside of the specified support hours, the end users received the following error message:

"Support Automation is currently closed. Please contact Service Desk Administrator". 

However if I use the direct link, like this example:

https://FQDN/CAisd/pdmweb.exe?OP=CREATE_NEW+FACTORY=sa_user_route+KEEP.itiltype=in+KEEP.launchType=1

You can access the system directly and bypass the hours of service. 

Why is this occurring and is there a way to keep the environment consistent? 
Environment:
Service Desk Manager 17.1 and older releases
Cause:
This is caused by a defect, which is being tracked with the id: DE41313
Resolution:
This defect will be addressed in a future published fix.

You may also use the following workaround to resolve the problem prior to the release of the published fix:

1. Open Web Screen Painter, and open the Employee version of detail_sa_user_route.htmpl. 

2. Find the following:

function call_save()
{
    window.setTimeout("detailSave()", 500);
}


and change it to look like the following: 

function call_save() 

if (check_sa_hours(undefined)){ 
window.setTimeout("detailSave()", 500); 

else { 
show_response (msgtext("SA_Closed")); 



3. Save and Publish the form.

4. From a command prompt run:

pdm_webcache 

5. Users may need to restart their browser session, or clear their browser cache for the change to be displayed.