Submitting a ticket to ServiceNow fails with the following error: "Invalid data major for field severity"

Document ID : KB000072246
Last Modified Date : 24/09/2018
Show Technical Document Details
Issue:
When using Spectrum 10.2 and the ServiceNow servicedesk integration submitting a ticket from Spectrum to ServiceNow fails with the following error message:

Error occurred while attempting to create a ticket in Service Desk. java.lang.Exception: {"Error":{"ErrorCode":157,"ErrorMessage":"Invalid data major for field severity. Possible values [[high, low, medium]]","HTTPResponseCode":"BAD_REQUEST","HTTPResponseCodeValue":400}}
Environment:
Spectrum 10.2
Spectrum 10.2.X
Cause:
The CA NIM Service Desk product field mapping  for the severity field contain possible values of "High=1,Medium=2,Low=3" and they need to be changed to "Critical=1,Major=2,Minor=3". 
Resolution:

1. Open the following URL on the OneClick server that's integrated with OneClick:  http://localhost:8080/spectrum/ca-nim-sm/login.jsp
2. Login with user: nimadmin password: nimadmin
3. Click on the Customization menu
4. Find the severity CA NIM field in the CA NIM and Service Desk product field mapping view and change the Possible Values from High=1,Medium=2,Low=3 to Critical=1,Major=2,Minor=3.
5. Click on the "Save" button in the upper right hand corner. 

After making the change you should no longer see the error creating submitting tickets in ServiceNow.