Strong Authentication installation error: JRE libraries are missing or not compatible

Document ID : KB000046962
Last Modified Date : 14/02/2018
Show Technical Document Details

Problem

When we install CA Strong Authentication by running the installer, we get below error:
 
====================
[root@myhostname CA]# sh CA-StrongAuthentication-8.1-Linux-Installer.bin
Preparing to install...
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

JRE libraries are missing or not compatible....
Exiting....
=================

Environment

Product: CA Strong Authentication(previously known as Arcot Webfort or CA AuthMinder) version 8.1
OS: RHEL (any supported release)

Cause

Two possible reasons of this error are:
1. No 32-bit library support: glibc.i686
2. There is no space or no permission on /tmp/ folder.

Resolution/Workaround

1. Install glibc.i686 using Yum command
$ yum install glibc.i686

2. Make sure there is sufficient space in /tmp/ folder and the linux user has full permission on /tmp/ folder.
Run the installer with "-x" option. This will display if any permission error during installation
e.g.
$ sh -x CA-StrongAuthentication-8.1-Linux-Installer.bin

WORK AROUND:
If it is not possible to provide required access to /tmp folder, you can use below workaround to install CA Advanced Authentication products using different folder as tmp folder:
1. Type these command in the terminal:
  a. sudo su
  b. cd /
  c. mkdir tmp2
  d. IATEMPDIR=/tmp2
  e. export IATEMPDIR
2. Now when you run the installer again it will launch successfully.

 Additional Information

Please make sure all system requirements are fulfilled. Please refer to CA Advanced Authentication - 8.1.x System Requirements for more details.