start up of dollar universe fails after the upgrade

Document ID : KB000087286
Last Modified Date : 14/04/2018
Show Technical Document Details
Issue:
Error Message :
 On the maintenance.log file we can read the following:
# -------------------------------------------------
# Problem during DUAS instance start.
# The following engines do not start:
# uxioserv_V6 X
# uxdqmsrv_V6 X
# -------------------------------------------------
Upgrade is successful, but there is an issue while starting DUAS server.
Check log /orsyp/universe/ESECDU/log/universe.log and try to restart the instance.

#--------------------------------------------------
# ---> ERROR:
# -------------------------------------------------

-----> Errors occur during upgrade, stop here.

#--------------------------------------------------
# Procedure aborted.

At the same time in the universe.log this error appears:

| 2016-10-20 14:32:51 |ERROR|X|IO |pid=21022.3086322368| u_ouv_serv | failed in u_listen: Errno syserror 98: Address already in use
| 2016-10-20 14:32:51 |FATAL|X|IO |pid=21022.3086322368| u_io_srv_main | Error opening IO server X service: port number in use (already started?) 

Patch level detected:Dollar Universe 6.6.21
Product Version: Dollar.Universe 6.6.21

Description :After the upgrade Dollar universe is not startup correctly
Even if the IO is startup some processes like CDJ, BVI cannot been startup
Environment:
OS: Linux
OS Version: Red Hat Enterprise Linux Server release 5.8 (Tikanga) but can be applied to another OS
Cause:
Cause type:
Configuration
Root Cause: During the upgrade procedure Dollar Universe v 5.x has not been stopped correctly.
Resolution:
Check that the duas 5.6 processes belong to the correct user (ex: univa). To do so, you can use the command ps -efHwl | grep ux
If your process belongs to a user which is not the administrator, you will need to execute the ux_dus_rights command:

-Log in as root
-Shutdown Dollar Universe
-Execute the following:
ux_dus_rights.sh univa universe LOW
- connect you with univa
- uxstartup

Then proceed with the upgrade using an Administrator or Root account.

Fix Status: No Fix
 
Additional Information:
Workaround :
N/A