SSO Portal Authentication stopped working again in dev and never worked on production

Document ID : KB000128873
Last Modified Date : 06/03/2019
Show Technical Document Details
Issue:

We recently updated certificates and switch from the deprecated SSO SAML authentication to new SAML authentication.  It was working a week ago in dev but never in production

Environment:
On-Prem gateway 9.3
SaaS Portal 4.2.10
 
Cause:
Service Provider ID did not match exactly what was configure as the service provider from ADFS 


 
Resolution:
When configuring SAML Authentication click  “Provider Configuration”
Service Provider ID
https://servername.mycompany.com
“Specify the service provider identification that identifies the CA API Portal service”
 
Value MUST match identical to the service provide defined this needs to include trailing slashes if they exist
 
Prod https://servername.prod.mycompany.com = failed with exception on portal with Null attributes
 
Production trailing slash was defined to fix changed
To