SQLserver probe connection error after TLS 1.2 upgrade

Document ID : KB000116616
Last Modified Date : 01/10/2018
Show Technical Document Details
Issue:
After the upgrade of TLS where TLS 1.0 is disabled and TLS 1.1/ 1.2 enabled but facing odbc drivers connection error while trying to connect to the database from the probe.

The below is the error we are facing:

sqlserver: Profile: test connection profile/test connection checkpoint/Connect - DB Provider: Code=0x80004005 Source=Microsoft OLE DB Provider for ODBC Drivers Description=[Microsoft][ODBC SQL Server Driver][DBNETLIB]ConnectionOpen (SECCreateCredentials()).
Environment:
UIM: 8.5.1
sqlserver: 5.40
Resolution:
Enable the FIPS parameter on the servers where you are facing the issue. FIPS should be enabled as by default it is disabled.

Refer the following link for enabling the FIPS.
https://ashwaniashwin.wordpress.com/tag/dbnetlib/

It is recommended to install the following probe (5.41) as it has fix when we disable the TLS 1.0.

1. Please make sure native client 11 is installed on robot where sqlserver probe is deployed.
https://www.microsoft.com/en-us/download/details.aspx?id=50402

2. Download the Beta version of sqlserver probe from the following link.
http://support.nimsoft.com/Default.aspx?center=felles/archive&state=BETA

3. Copy the file to primary hub archive.

4. Once the native client is installed, drag and drop the probe to target robot.

5. Cold start (Deactivate and Activate) the probe the probe.

6. Test the connection error