SPS not taking symbolic links

Document ID : KB000107009
Last Modified Date : 19/07/2018
Show Technical Document Details
Issue:
We are standing up a new 12.8 CA SSO AG (Aceess Gateway, also known as SPS) servers on CentOS 7. Currently on all the CentOS hosts, we install all applications under /apps and /apps is actually a symbolic link (i.e. soft link) to /local, made with e.g. "ln -s /local /apps" command. When I perform the CA access gateway installation, even though I give the installation path as /apps/CA, it had all the config files with path /local after configuration . So need to understand why CA AG did not take the symbolic link ?

What I meant was in the WebAgent.conf file all the path are:

/local/CA/secure-proxy 

Instead of 

/apps/CA/secure-proxy: 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
HostConfigFile="/local/CA/secure-proxy/proxy-engine/conf/defaultagent/SmHost.conf" 
AgentConfigObject="aco-iadd1sliama3001-ag" 
ServerPath="ServerPath_default" 
EnableWebAgent="YES" 
#localconfigfile="/local/CA/secure-proxy/proxy-engine/conf/defaultagent/LocalConfig.conf" 
LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libHttpPlugin.so" 
LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libSPSPlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libSPPlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libDisambiguatePlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libOpenIDPlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libSessionLinkerPlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libSAMLDataPlugin.so" 
#LoadPlugin="/local/CA/secure-proxy/agentframework/bin/libCertSessionLinkerPlugin.so" 
AgentIdFile="/local/CA/secure-proxy/proxy-engine/conf/defaultagent/AgentId.dat" 
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Environment:
All SSO Versions
Resolution:
Installation/configuration of CA Access Gateway on symbolic link location is functionally not supported as of now.