SPS is not able to connect to backend

Document ID : KB000046981
Last Modified Date : 14/02/2018
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Issue: 

We could see that the request is failing when it is trying to make a connection to backend.

Below error is coming in the browser:

Secure Proxy Server - Error Report

Error Details

Request URI

: /

Error Type

: SPS Exception

Error Code

: Noodle_ConnectException

Message

: Connection refused remotely, no process is listening on the remote address/port

Below are the logs:

[09/27/2016][09:01:37][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][execute][Sending request to backend = si.gets.georgia.gov url = http://www.backend.ca.com]

[09/27/2016][09:01:37][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][requestConnection(): ][Get connection: HttpRoute[{}->http://www.backend.ca.com], timeout = 180000]

[09/27/2016][09:01:37][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][openConnection()][Connecting to www.backend.ca.com/16.96.234.109:80]

[09/27/2016][09:01:38][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][releaseConnection(): ][Released connection is not reusable.]

[09/27/2016][09:01:38][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][execute][Connection to http://www.backend.ca.com refused]

[09/27/2016][09:01:38][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][execute][Retrying to send the request to backend web server.Retry count: 1]

[09/27/2016][09:01:38][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][Noodle::doGet][org.apache.http.conn.HttpHostConnectException: Connection to http://www.backend.ca.com refused at com.ca.proxy.apache.httpclient.conn.factory.SPSConnectionFactory.openConnection(SPSConnectionFactory.java:143)]

[09/27/2016][09:01:38][5276][5508][20895217-a1efb570-f49946af-181e7251-34d1e3aa-73f][ProxyValve::invoke][Leaving the agent.]

Environment:  

Applicable for all environments

Cause: 

The error is either a Network or Back-end Server issue

backend is refusing the connection or some network component is blocking the connection to backend

Here in the above use case, customer was having IP conflict issue with the backend IP address and which caused this issue.

Resolution:

Network Team corrected the IP conflict issue in this case(But it is not the same issue all the time and it could be anything with the backend or network).

Please work with your network team/backend server team to resolve the issue.

Additional Information:

https://communities.ca.com/thread/241727869