SPS forwarding is being redirected to a local host instead of the backend server

Document ID : KB000008342
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

We're running SPS, and the resources are forwarded to localhost instead of to be forwarded to the configured backend server: 

Agent_trace:

[09/29/2017][02:50:48][5640][5900][2192c32c-b87f00b1-2105d0e1-8d608099-516e0da7-4b][SmProxyRules.processRules][Dispatching to service FORWARD with url http://abc.com:88$2]

being resolved to Local host:

 

[09/29/2017][02:50:48][5640][5900][2192c32c-b87f00b1-2105d0e1-8d608099-516e0da7-4b][execute][Sending request to backend = localhost:80 url = http://localhost:80/index.html]

Environment:
Policy Server: 12.6 SP1 64 bit proxy Server: 12.6 SP1 64 bit
Cause:

The Forward Syntax in the proxy rule was not set correctly

Resolution:

Changing the value for the forward syntax from

<nete:forward>http://proxy.company.com$2</nete:forward>

 

to 

 

 

<nete:forward>http://proxy.company.com$0</nete:forward>

 

resolved the issue

 

Further information:

$0

Appends the entire URI string from the user request to the destination specified in the proxy rule.

 

For example, if a proxy rule forwards all user requests for www.company.com to proxy.company.com$0, and a user requests for www.company.com/employees/hr/index.html, that request is forwarded to proxy.company.com/employees/hr/index.html. 

 

Additional Information:

https://docops.ca.com/ca-single-sign-on/12-6-01/en/configuring/ca-access-gateway-configuration/configure-proxy-rules-manually