Spectrumgtw probe not updating bi-direction alarms correctly

Document ID : KB000106069
Last Modified Date : 12/07/2018
Show Technical Document Details
Issue:
UIM 8.51 with Spectrumgtw probe v8.65 connecting to a Spectrum server 10.2.3.000. "BI-DIRECTIONAL" alarm sync has been selected, but UIM alarms under Spectrum OneClick, and Spectrum alarms are not seen in the UMP Alarm View. When looking at the Spectrum OneClick console we do see alarms from UIM being created. The problem is just Spectrum alarms to UIM.
 
Environment:
UIM 8.51 SP1
spectrumgtw 8.65HF3
spectrum UIM Services 8.65
ems 10.17
nas 9.0HF2

Spectrum 10.2.3
  Integration set to 'SpectrumGateway Integration' in OneClick Web Interface

 
Cause:
In the EMS.log we saw SQL exceptions regarding inserting data into the NAS_ALARMS table.
 
Resolution:
It appears that the backend NAS tables were not altered adding new columns introduced and needed by
  EMS 10.1x and NAS 9.x. This was causing the inserts to fail and the alarms therefore were not visible.

 
Additional Information:
  • deactivate nas
  • deactivate spectrumgtw
  • deactivate ems
  • drop the backend NAS_ database tables
DROP TABLE NAS_VERSION
DROP TABLE NAS_ALARMS
DROP TABLE NAS_TRANSACTION_LOG
DROP TABLE NAS_TRANSACTION_SUMMARY
  • delete the db folder from the ems probe directory  \Nimsoft\probes\service\ems\db
  • delete the cache folder from the spectrumgtw probe directory \Nimsoft\probes\gateway\spectrumgtw\cache
  • activate the nas probe (it will recreate the backend tables)
  • activate the ems probe
  • activate the spectrumgtw probe