Spectrum SPM test is timing out: HTTP server indicated error 400: HTTP/1.1 400 Bad Request

Document ID : KB000108064
Last Modified Date : 27/07/2018
Show Technical Document Details
Issue:
  • HTTPS test is timing out from Spectrum.
  • jcollector.log (loglevel=7)
[LOG_DEBUG][2018-07-24 15:19:39][Thread:Thread-152][Pass #13]: read header: HTTP/1.1 400 Bad Request 
[LOG_CRITICAL][2018-07-24 15:19:39][Thread:Thread-152][Pass #13]: [#41890783] ERRSRC:https ERRCODE:400 INDEX:41890783 NAME: TESTDESC:Openshift_Stratus_Test ERROR: jcollector.SATestException: Error downloading object: jcollector.SATestException: https://website.ca.com : jcollector.SATestException: HTTP server indicated error 400: HTTP/1.1 400 Bad Request 
jcollector.SATestException: Error downloading object: jcollector.SATestException: https://website.ca.com : jcollector.SATestException: HTTP server indicated error 400: HTTP/1.1 400 Bad Request 
at jcollector.HTTPTools.downloadPage(Unknown Source) 
at jcollector.HttpTestBase.downloadPage(Unknown Source) 
at jcollector.HttpTestBase.execTest(Unknown Source) 
at jcollector.HTTPSTest.execTest(Unknown Source) 
at jcollector.SATest.go(Unknown Source) 
at jcollector.TestThread.run(Unknown Source) 
Cause:
  • There can be multiple cases for SPM tests to fail.
  • It is best to reproduce the failing test with the SRM AIM In debug:
  1. Stop SystemEDGE
  2. Navigate to C:\Users\Public\CA\SystemEDGE\port1691\plugins\svcrsp\svcrsp.cf
  3. set loglevel=7
  4. Start SystyemEDGE
  5. Review jcollector.log for errors.
Resolution:
  • Server is rejecting the SRM AIM request: HTTP server indicated error 400: HTTP/1.1 400 Bad Request 
  1. Stop SystemEDGE
  2. Navigate to C:\Users\Public\CA\SystemEDGE\port1691\plugins\svcrsp\svcrsp.cf
  3. Uncomment useragent parameter
     #useragent="Mozilla/5.0 (compatible; MSIE 9.0; Windows NT 7.1; Trident/5.0)"

       4.  Start SystyemEDGE
  • Enabling the SRM AIM to impersonate a well known browser when running the test, the sever accepts the request.
Additional Information: