Spectrum Service Performance Manager (SPM) proxy http test times out

Document ID : KB000049662
Last Modified Date : 14/02/2018
Show Technical Document Details

Description:

Customers can create an HTTP Service Performance Manager (SPM) test and specify a proxy URL, but no proxy user. When this is done an alarm is generated stating the test timed out:

SPM TEST TIMED OUT

Symptoms:
A remote RTT test operation timed out.

Probable Causes:

  1. The path between the remote host and the destination is either down or very slow.

  2. The destination device is either down or very slow.

  3. The timeout is set too low.

  4. SPM was unable to obtain results from the test host for an unknown reason.

Recommended Actions:

  1. Launch the results view and use the test results history to help decide if the timeout is appropriate. Increase the timeout if it is deemed too low.

  2. If the timeout is appropriate, either the network or the destination is down or overloaded.

Logging into the router and creating a test using the same parameters, succeeds.

The cause of the problem is how SPM creates the test, using encryption for the user field. On the router, the http-raw-request looks like this:

GET http://ca.com HTTP/1.0 \r\n
Proxy-Authorization: Basic Og==\r\n
\r\n

The correct syntax should be this:

GET http://www.ca.com HTTP/1.0\r\n
\r\n

Solution:

This will be fixed in the 9.2.2 version of Spectrum.

Until 9.2.2 is released, customers can work around this issue by manually creating the test on the router and then discover the test in SPM using a read-only test discovery.

References:
Configuring Cisco IOS IP SLAs HTTP Operations
IP SLAs Configuration Guide, Cisco IOS
Cisco IOS IP SLAs Command Reference
CA Spectrum Service Performance Manager User Guide

File Attachments:
TEC568514.zip