Spectrum Report Manager reports time out before displaying the report.

Document ID : KB000007020
Last Modified Date : 14/02/2018
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Issue:

Spectrum Report Manager (SRM) reports time out before displaying the report. The following error is seen:

name: MochiKit.Async.XMLHttpRequestError

description:

message:

Request failed number: 12002

Cause:

The root cause may be the reporting database contains more landscapes than configured in the Report Manager Spectrum Status web page. To verify, do the following:

1. Log into the OneClick web pages as an ADMIN user

2. Click on the Administration link

3. Click on the Report Manager link

4. Click on the SPECTRUM Status link

5. Note the landscapes listed in the SPECTRUM Status web page

6. Log into the OneClick/SRM system as the user that owns the Spectrum installation

7. cd to the $SPECROOT/mysql/bin directory

8. Enter the following command to log into mysql:

 ./mysql --defaults-file=../my-spectrum.cnf -uroot -proot reporting

9. Enter the following command at the mysql prompt to display the number of landscapes in the reporting database:

select distinct(landscape_h) from model; 

The output will look similar to the following:

mysql> select distinct(landscape_h) from model;

+-------------+

| landscape_h |

+-------------+

|     1048576 |

|     8388608 |

|     9437184 |

|    10485760 |

|    17825792 |

|   210763776 |

+-------------+

6 rows in set (0.00 sec)

If the number of landscapes shown after running the "select distinct(landscape_h) from model;" command is greater than the number of landscapes shown in the OneClick SPECTRUM Status web page, then this may be the issue.

Although these extra landscapes are not configured to be monitored in the OneClick SPECTRUM Status web page, SRM does poll them at OneClick startup to collect their model information.

When OneClick is started, it connects to the Main Location Server specified in the OneClick SPECTRUM Configuration web page. It reads the Location Server cache and attempts to connect to ALL landscapes read from the cache. If it can connect, it will read the model information from that landscape and store it in the reporting database. If the landscape is configured to be monitored, it will start collecting Event and alarm information.

Resolution:

To resolve this issue, perform the following steps:

1. Shutdown tomcat on the SRM system

2. cd to the $SPECROOT/bin directory

3. Run the RpmgrInitializeLandscape.sh (Linux and Solaris) RpmgrInitializeLandscape.bat (Windows) to remove all landscapes that are not being monitored from the reporting database. Refer to the Reporting Database Management section of the Spectrum documentation for information on running the RpmgrInitializeLandscape script.

4. Log into each SpectroSERVER system that is not to be monitored by this SRM system and remove the hostname/ip address of the SRM system from the $SPECROOT/.hostrc file. This will prevent SRM from being able to connect to the SpectroSERVER at OneClick startup.

5. Start tomcat as normal

6. Rerun the "select distinct(landscape_h) from model;" to ensure only those landscapes being monitored are in this list.