SPECTRUM OneClick stating "This model has no interfaces" in the Interfaces tab (Legacy KB ID CNC TS31765 )

Document ID : KB000051921
Last Modified Date : 14/02/2018
Show Technical Document Details
Performed the following steps to clear up the database corruption resolved the issue:


1. Shutdown the SpectroSERVER
2. Open a terminal window or bash shell
3. cd to the $SPECROOT/SS directory
4. Enter the following command to create a models only database save


../SS-Tools/SSdbsave -m models_only


5. Enter the following command to initialize the database to to legacy catalog


../SS-Tools/SSdbload -il legacy.SSdb


6. Enter the following command to load the models only save from step 4


../SS-Tools/SSdbload -m models_only.SSdb


7. Start the SpectroSERVER and verify the model now has interfaces configured



Related Issues/Questions:
SPECTRUM OneClick stating "This model has no interfaces" in the Interfaces tab.

Problem Environment:
SPECTRUM 09.00.00.00
User migrated database from SPECTRUM 08.01.00.00 to SPECTRUM 09.00.00.00. For some models, the OneClick Interfaces tab displays "This model has not interfaces".
MIB Tools query confirms there are interfaces configured on this device.
Modeling the same device on another SpectroSERVER does not display this issue.
Loading the SPECTRUM 09.00.00.00 database on a test system and modeling the device displays the same issue.
Reconfiguring the SPECTRUM model did not resolve the issue.

Causes of this problem:
The root cause of the issue was database corruption


(Legacy KB ID CNC TS31765 )