Spectrum OneClick client taking long time to launch because of expired cert

Document ID : KB000125102
Last Modified Date : 22/01/2019
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Issue:
Spectrum OneClick client taking long time to launch because of expired cert
Environment:
Spectrum OneClick 10.x
Cause:
JRE certificate expired
Resolution:
A new JRE certificate is included in Spectrum 10.03.01.00. 

New JRE certificate patches are planned for supported releases. No projected release date set at the time of this knowledge document posting.

Please contact Spectrum Support for more information.
Additional Information:
The following work-around can be done on each client system.

This one is still slow but not as slow as before:

1. Launch the Java Control Panel
2. Click on the Advanced tab
3. Scroll down and find the "Perform signed code certificate revocation checks on" section. Depending on the version of Java, it may be "Perform Certificate revocation checks on"
4. Set it back to "All certificates in the chain of trust"
5. Find the "Mixed code" section and set it to "Enabled- hide warning and run with protection" and click on the Apply button
6. Click on the Security tab and add the OneClick system to the Exception Site List Apply and exit

This one is not slow:

1. Launch the Java Control Panel
2. Click on the Advanced tab
3. Scroll down and find the "Perform signed code certificate revocation checks on" section. Depending on the version of Java, it may be "Perform Certificate revocation checks on"
4. If not set to "Do not check (not recommended)" can you set it to "Do not check (not recommended)", Apply