Spectrum installation error "Following applications are running"

Document ID : KB000004328
Last Modified Date : 14/02/2018
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Issue:

During a Spectrum installation of a release version or upgrade, you may receive an error indicating some applications are still running, which may cause installer to fail. The error requests to close the applications to continue. The installer will not proceed without stopping these applications first.

 install_error_files_runnnig.PNG

Environment:
Spectrum 9.xSpectrum 10.XOS Platform Independent
Cause:

The Installer normally shuts down the processes in order to perform the upgrade. In some cases, some processes may not have shut down.  

Resolution:

The error will indicate which processes are still running. The list of processes may vary.

To ensure all Spectrum processes are shut down, verify the following

-      SpectroSERVER is STOPPED

o    Stop SS from Spectrum Control Panel.

o    Or from <SPECROOT>/bin run ./stopSS.pl

-      Processd is STOPPED

o    Stop from <SPECROOT>/lib/SDPM directory.

o    Run ./processd.pl stop

If stopping these two services does not solve the issue, then check for the running processes.

In Windows, check Task Manager
In Linux / Bash shell, run ps -f | grep <processname>

Kill the processes

Note: In Windows Task Manager, some processes such as nameserv.exe may show up as a SPECTRUM Javawrap process. You can stop these as well.

 

Note: DO NOT shutdown sradmin.exe – the installer requires this to run. 

Additional Information:

Processes used by Spectrum:

SpectroSERVER.exe
Processd.exe
ArchMgr.exe (stopped from SCP)
SCP.exe
AlarmNotifier.exe
LocServ.exe
nameserv.exe
ncmservice.exe
telned.exe
mysqld.exe (not the same as mysql.exe)
mysql.exe (do not kill mysql.exe – this should be gracefully shutdown using cmdC)
Vnmshd.exe

Additional processes on OneClick Servers:

 

OneClickService.exe (Spectrum Tomcat)
Java.exe