Spectrum IM Connector 2.0.0.244 does not startup with IFW 3.3 CUM2

Document ID : KB000006511
Last Modified Date : 14/02/2018
Show Technical Document Details
Issue:

Spectrum IM Connector version 2.0.0.244 fails to startup in Integration Framework SOI 3.3 CUM2

Environment:
Spectrum IM Connector 2.0.0.244SOI 3.3 CUM2
Cause:

SOI 4.0 SP2 Integration Framework is upgraded to JRE 1.8 and therefore Spectrum IM Connector 2.0.0.244 is not longer compatible with

SOI 3.3 CUM2 Integration Framework because this is using JRE 1.7.

 

Error message you will see in the SOI\jsw\logs\SAM-IntegrationServices_wrapper.log file are as follows:

 

INFO   | jvm 1    | 2017/04/13 13:46:27 | WrapperStartStopApp Error: Encountered an error running start main: java.lang.UnsupportedClassVersionError: com/ca/usm/ucf/spectrum/SpectrumUCFConnector : Unsupported major.minor version 52.0
INFO   | jvm 1    | 2017/04/13 13:46:27 | WrapperStartStopApp Error: java.lang.UnsupportedClassVersionError: com/ca/usm/ucf/spectrum/SpectrumUCFConnector : Unsupported major.minor version 52.0

 

Resolution:

If there are important reasons not to upgrade SOI 3.3 CUM2 to SOI 4.0 SP2 for the time being to be able to use the new Spectrum IM Connector version

2.0.0.244 you can use Spectrum IM Connector version 2.0.0.238 and the patch 2.0.0.240 instead.

The patch 2.0.0.240 can be requested from CA Support through a support case.