Spectrum CI not getting created in Service desk

Document ID : KB000073231
Last Modified Date : 13/04/2018
Show Technical Document Details
Question:
On OneClick Administration in ServiceDesk integration page, I have enabled configuration for the Item, but still the configuration Item is not displaying  in ServiceDesk tickets?

From the logs , we can see this authentication error:

Feb 20, 2018 12:05:08.589 - Error occurred while attempting to create a ticket in Service Desk. AHD03300:This operation requires Function Access for ci equal to View or Modify
Feb 20, 2018 12:05:08.589 (AlarmNotifier) (SDIntegration) - SDAlarmHandler - received alarm UPDATE
Feb 20, 2018 12:05:08.589 (AlarmNotifier) (SDIntegration) - SDUpdateAction - troubleshooter has been assigned for alarm 5a8be49c-97b7-1003-03eb-0050569c7588
Feb 20, 2018 12:05:08.604 - Error occurred while closing a Service Desk ticket. AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Client
faultSubcode: 
 faultString: Internal err with get_object_values: NOT FOUND
faultActor: 
 faultNode: 
 faultDetail: 
                {}ErrorMessage:Internal err with get_object_values: NOT FOUND
                {}ErrorCode:102

Internal err with get_object_values: NOT FOUND
                at org.apache.axis.message.SOAPFaultBuilder.createFault(SOAPFaultBuilder.java:222)
                at org.apache.axis.message.SOAPFaultBuilder.endElement(SOAPFaultBuilder.java:129)
Environment:
Spectrum Version 10.0 through 10.2.3
ServiceDesk Version 12.7, 14.1, 17.0
Answer:

The Attribute "ServiceDesk_asset_ID" is enough to create CI in Service Desk. 
Value will be generated or set after ticket has been created in service Desk. This problem is with user permissions only.

To resolve the ServiceDesk User who is trying to create ServiceDesk tickets should  have permissions to create configuration Item in ServiceDesk.